Network Kings

What is EIGRP?

Introduction of EIGRP

EIGRP stands for Enhanced Interior Gateway Routing Protocol. It is made by Cisco, before 2013 it was Cisco proprietary, but now it is open to all. But still some features are only supported to Cisco devices.

It works on DUAL (Diffuse Update Algorithm).

AD value of EIGRP = 90, External EIGRP =170

Hello packet has a 5 second timer and hold-down timer is of 15 sec. EIGRP running routers send hello packets to their neighbors every 5 sec. After sending hello message, it will wait up to 15 sec (hold-down time interval).

In EIGRP, maximum routers could be 255, by default this value is 100.

EIGRP uses 224.0.0.10 multicast address.

It supports subnetting.

EIGRP has faster convergence.

What is convergence?

In a network, there are multiple paths to reach a same destination. And only best routes are selected and placed in routing table. Whenever a link goes down, how fast a protocol response to forward the traffic to other routes that is called convergence. For a good routing protocol convergence time should be less. Don’t be confuse in convergence time and rate – always remember convergence time should be less and convergence rate should be faster.

I am saying this because I remember in one my interview, interviewer ask a question how EIGRP is better than OSPF?

And in hurry, I said in EIGRP convergence time is higher, and then he said really. Could you explain me this? And when I was explaining then I realized what mistake I did. Then, I said sorry sir, for a good routing protocol convergence time should be less.

EIGRP has 3 tables

  1. Neighbor Table
  2. Topology Table
  3. Routing Table
Introduction of EIGRP EIGRP stands for Enhanced Interior Gateway Routing Protocol. It is made by Cisco, before 2013 it was Cisco proprietary, but now it is open to all. But still some features are only supported to Cisco devices. It works on DUAL (Diffuse Update Algorithm). AD value of EIGRP = 90, External EIGRP =170 Hello packet has a 5 second timer and hold-down timer is of 15 sec. EIGRP running routers send hello packets to their neighbors every 5 sec. After sending hello message, it will wait up to 15 sec (hold-down time interval). In EIGRP, maximum routers could be 255, by default this value is 100. EIGRP uses 224.0.0.10 multicast address. It supports subnetting. EIGRP has faster convergence. What is convergence? In a network, there are multiple paths to reach a same destination. And only best routes are selected and placed in routing table. Whenever a link goes down, how fast a protocol response to forward the traffic to other routes that is called convergence. For a good routing protocol convergence time should be less. Don’t be confuse in convergence time and rate – always remember convergence time should be less and convergence rate should be faster. I am saying this because I remember in one my interview, interviewer ask a question how EIGRP is better than OSPF? And in hurry, I said in EIGRP convergence time is higher, and then he said really. Could you explain me this? And when I was explaining then I realized what mistake I did. Then, I said sorry sir, for a good routing protocol convergence time should be less. EIGRP has 3 tables Neighbor Table Topology Table Routing Table EIGRP Tables 1. Neighbor Table – Neighbor table have the information of all directly connected neighbors. Each EIGRP running router manages its own neighbor table. For example, according to below network topology, In R5 neighbor table R3 and R1 router information, in R3 neighbor table router R5 and R4 information and so on. 2. Topology Table – Topology table manages the information of all the networks. 3. Routing Table- Routing table has information of best routes. Best routes are selected on the basis of prefix value, AD value and metric value. Lower value of AD and metric are preferred while in case of prefix higher value is preferred. EIGRP running routers depend on neighbor routers for path information. While in OSPF each router has a topology map in their memory so, each router has information of all routes. For more clarity, here I am giving you an example- suppose you have to go somewhere, you know destination but don’t know the path in that case what you do? You will take help from other people. Similarly in EIGRP, routers don’t know the path, they depend on routers for route information. To explain OSPF I am taking another example in which you know the destination as well as the path. EIGRP Messages 1.Hello 2.Update 3.Acknowledge 4.Query 5.Reply Hello: EIGRP use Hello packet to discover neighbors. Hello packet use multicast address 224.0.0.10. Hello packet timer is 5 sec. Update: This packet is used to send routing information. EIGRP unicast update message to send routing information to newly discovered neighbor. Update messages are multicasted when a link or metric changes, so every routers update their table. Acknowledgement: In the response of update to acknowledge the sender EIGRP sends acknowledge packet. It is a hello packet with no data and unicast to sender. Query: When primary link fails due to some reason, EIGRP sends query packet to find backup route to destination. Query packets always multicast. Reply: EIGRP sends reply in response of query. It provides backup route information to sender. It is unicast message. How to configure EIGRP? router eigrp <AS number> network <network Id> ## EIGRP LAB ## Now we fill perform a EIGRP Lab. To perform this lab, I used Cisco packet tracer. First design the topology, Here I used 4 routers, then make connections. Configurations: Configuration is very simple, first configure the router interfaces with ip address. interface <interface type><interface name> ip address <ip address> <subnet mask> no shutdown After this configure the EIGRP router eigrp <autonomous system number> network <network Id> no auto-summary Same steps are repeated in all 4 routers. ##R1 Configuration ## enable configure terminal hostname R1 interface fa0/0 ip address 192.168.10.1 255.255.255.0 no shutdown int fa0/1 ip add 192.168.20.1 255.255.255.0 no shutdown router eigrp 100 network 192.168.20.0 network 192.168.10.0 ##R2 Configuration ## enable configure terminal hostname R2 interface fa0/0 ip address 192.168.40.1 255.255.255.0 no shutdown int fa0/1 ip add 192.168.20.2 255.255.255.0 no shutdown router eigrp 100 network 192.168.20.0 network 192.168.40.0 ## R3 Configuration ## enable configure terminal hostname R3 interface fa0/0 ip address 192.168.30.2 255.255.255.0 no shut int fa0/1 ip add 192.168.40.2 255.255.255.0 no shutdown router eigrp 100 network 192.168.30.0 network 192.168.40.0 ## R4 Configuration ## enable configure terminal hostname R4 interface fa0/0 ip address 192.168.10.2 255.255.255.0 no shut int fa0/1 ip add 192.168.30.1 255.255.255.0 no shutdown router eigrp 100 network 192.168.10.0 network 192.168.30.0 Result: Here I am submitting ping result. I ping router 3 interface from router 1 (refer above diagram). You can see in image R1 and R3 are not directly connected, routes are dynamically learn by eigrp protocol. You can also see the routes in routing table by using show ip route command (enable mode command). Ping command is also run in enable mode. EIGRP got ping reply- lab successful! I got the ping reply. It means my lab is successful.

 

EIGRP Tables

1. Neighbor Table – Neighbor table have the information of all directly connected neighbors. Each EIGRP running router manages its own neighbor table. For example, according to below network topology, In R5 neighbor table R3 and R1 router information, in R3 neighbor table router R5 and R4 information and so on.

EIGRP Tables

2. Topology Table – Topology table manages the information of all the networks.

3. Routing Table- Routing table has information of best routes. Best routes are selected on the basis of prefix value, AD value and metric value. Lower value of AD and metric are preferred while in case of prefix higher value is preferred.

EIGRP running routers depend on neighbor routers for path information. While in OSPF each router has a topology map in their memory so, each router has information of all routes.

For more clarity, here I am giving you an example- suppose you have to go somewhere, you know destination but don’t know the path in that case what you do?  You will take help from other people. Similarly in EIGRP, routers don’t know the path, they depend on routers for route information.

To explain OSPF I am taking another example in which you know the destination as well as the path.

EIGRP Messages

1.Hello
2.Update
3.Acknowledge
4.Query
5.Reply

Hello: EIGRP use Hello packet to discover neighbors. Hello packet use multicast address 224.0.0.10. Hello packet timer is 5 sec.

Update: This packet is used to send routing information.  EIGRP unicast update message to send routing information to newly discovered neighbor. Update messages are multicasted when a link or metric changes, so every routers update their table.

Acknowledgement: In the response of update to acknowledge the sender EIGRP sends acknowledge packet. It is a hello packet with no data and unicast to sender.

Query: When primary link fails due to some reason, EIGRP sends query packet to find backup route to destination. Query packets always multicast.

Reply: EIGRP sends reply in response of query. It provides backup route information to sender. It is unicast message.

How to configure EIGRP?

router eigrp <AS number>
network <network Id>

 

                      ## EIGRP LAB ##

 

Now we fill perform a EIGRP Lab. To perform this lab, I used Cisco packet tracer. First design the topology, Here I used 4 routers, then make connections.

EIGRP LAB

Configurations:

Configuration is very simple, first configure the router interfaces with ip address.

interface <interface type><interface name>
ip address <ip address> <subnet mask>
no shutdown


After this configure the EIGRP

router eigrp <autonomous system number>
network <network Id>
no auto-summary

Same steps are repeated in all 4 routers.

##R1 Configuration ##

enable
configure terminal
hostname R1
interface  fa0/0
ip address 192.168.10.1 255.255.255.0
no shutdown
int fa0/1
ip add 192.168.20.1 255.255.255.0
no shutdown
router eigrp 100
network 192.168.20.0
network 192.168.10.0
 

##R2 Configuration ##

enable
configure terminal
hostname R2
interface  fa0/0
ip address 192.168.40.1 255.255.255.0
no shutdown
int fa0/1
ip add 192.168.20.2 255.255.255.0
no shutdown
router eigrp 100
network 192.168.20.0
network 192.168.40.0

## R3 Configuration ##

enable
configure terminal
hostname R3
interface  fa0/0
ip address 192.168.30.2 255.255.255.0
no shut
int fa0/1
ip add 192.168.40.2 255.255.255.0
no shutdown
router eigrp 100
network 192.168.30.0
network 192.168.40.0

## R4 Configuration ##

enable
configure terminal
hostname R4
interface  fa0/0
ip address 192.168.10.2 255.255.255.0
no shut
int fa0/1
ip add 192.168.30.1 255.255.255.0
no shutdown
router eigrp 100
network 192.168.10.0
network 192.168.30.0

Result: Here I am submitting ping result. I ping router 3 interface from router 1 (refer above diagram). You can see in image R1 and R3 are not directly connected, routes are dynamically learn by eigrp protocol. You can also see the routes in routing table by using show ip route command (enable mode command). Ping command is also run in enable mode.

 

EIGRP got ping reply- lab successful!

I got the ping reply. It means my lab is successful.