Network Kings

LIMITED TIME OFFER

$999 $499 only For All Access Pass Today! USE PROMO CODE : LIMITED

d :
h :
m

What is Route Summarization?: Explained

route summarization

Route summarization, also known as route aggregation or supernetting, is a technique used in networking to reduce the number of routes in a routing table by combining multiple smaller subnets into a single larger network address. Route Summarization helps simplify and optimize routing in a network. It can be used in routing protocols like OSPF, EIGRP, and BGP.

What are the advantages of Route Summarization?

The advantages of Route Summarization are as follows-

  • The key benefit of route summarization is a smaller routing table. Since with the help of summarization, multiple routes are aggregated into a single summarized route, routing table size decreases. 
  • Summarization helps in saving bandwidth. Since the routing table is reduced, less information must be exchanged between routers during the routing protocol updates. This leads to more efficient use of network bandwidth and faster convergence in response to network changes 
  • Route Summarization also helps to save CPU memory and less processing since routes are fewer and hence fewer packets to process. 

How to summarize routes?

  • First, list all the subnets you want to summarize. These subnets should be contiguous. 

Let’s take  

  1. 172.16.0.0/24 
  2. 172.16.1.0/24 
  • Convert the subnets to binary form.  

172.16.0.1/24: – 10101100000100000000000000000001 

172.16.1.1/24: – 10101100000100000000000100000001 

  • Calculate the number of common bits in this binary format. 

10101100000100000000000000000001 

10101100000100000000000100000001 

Here we have 23 bits in common. 

Hence our summary address subnet mask will be /23 and the summary address will be 172.16.0.0/23 

Configuration: – 

Let us look at the configuration of Summarization using the topology below. 

EIGRP configuration

Router#configure terminal  

Router(config)#hostname R1 

R1(config)#interface fastEthernet 0/0 

R1(config-if)#ip address 192.168.12.1 255.255.255.0 

R1(config-if)#no shutdown  

R1(config-if)#exit 

R1(config)#interface loopback 0 

R1(config-if)#ip address 172.16.0.1 255.255.255.0 

R1(config-if)#exit 

R1(config)#interface loopback 1 

R1(config-if)#ip address 172.16.1.1 255.255.255.0 

R1(config-if)#exit 

 

EIGRP CONFIGURATION: – 

 

R1(config)#router eigrp 1 

R1(config-router)#no auto-summary  

R1(config-router)#network 192.168.12.0 

R1(config-router)#network 172.16.0.0 

R1(config-router)#exit 

 

R2: – 

 

Router#configure terminal  

Router(config)#hostname R2 

R2(config)#interface fastEthernet 0/1 

R2(config-if)#ip address 192.168.12.2 255.255.255.0 

R2(config-if)#no shutdown  

R2(config-if)#exit 

 

EIGRP CONFIGURATION: – 

 

R2(config)#router eigrp 1 

R2(config-router)#no auto-summary  

R2(config-router)#network 192.168.12.0 

 

*Mar 1 00:05:27.191: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.12.1  

(FastEthernet0/1) is up: new adjacency 

 

EIGRP is UP.  

 

Verification: –  

 

Let us check the routes on R1 and R2 

 

R1#show ip route  

Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP 

       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area  

       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2 

       E1 – OSPF external type 1, E2 – OSPF external type 2 

       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2 

       ia – IS-IS inter area, * – candidate default, U – per-user static route 

       o – ODR, P – periodic downloaded static route 

 

The Gateway of last resort is not set 

 

C 192.168.12.0/24 is directly connected, FastEthernet0/0 

     172.16.0.0/24 is subnetted, 2 subnets 

C 172.16.0.0 is directly connected, Loopback0 

C 172.16.1.0 is directly connected, Loopback1 

 

R2#show ip route eigrp  

     172.16.0.0/24 is subnetted, 2 subnets 

D 172.16.0.0 [90/409600] via 192.168.12.1, 00:01:47, FastEthernet0/1 

D 172.16.1.0 [90/409600] via 192.168.12.1, 00:01:47, FastEthernet0/1 

 

R2#show ip route  

Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP 

       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area  

       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2 

       E1 – OSPF external type 1, E2 – OSPF external type 2 

       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2 

       ia – IS-IS inter area, * – candidate default, U – per-user static route 

       o – ODR, P – periodic downloaded static route 

 

The Gateway of last resort is not set 

 

C 192.168.12.0/24 is directly connected, FastEthernet0/1 

     172.16.0.0/24 is subnetted, 2 subnets 

D 172.16.0.0 [90/409600] via 192.168.12.1, 00:02:57, FastEthernet0/1 

D 172.16.1.0 [90/409600] via 192.168.12.1, 00:02:57, FastEthernet0/1 

 

R2#ping 172.16.0.1 

 

Type escape sequence to abort. 

Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds: 

!!!!! 

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/20 ms 

 

We can ping 172.16.0.1 hence it is reachable. 

 

Summarization: – 

 

Since we have already calculated the summarized network for 172.16.0.0/24, 172.16.1.0/24 which is 172.16.0.0/23. Let’s configure it. 

 

R1#configure terminal  

R1(config)#interface fastEthernet 0/0  

R1(config-if)#ip summary-address eigrp 1 172.16.0.0 255.255.254.0 

 

*Mar 1 00:09:54.743: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.12.2  

(FastEthernet0/0) is resync: summary configured 

EIGRP configuration

The above message pops up which shows that summarization is configured. 

 

R2: – 

 

*Mar 1 00:09:32.251: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.12.1  

(FastEthernet0/1) is resync: peer graceful-restart 

EIGRP configuration

The above message pops up which shows that summarization is configured. 

 

R2: – 

 

*Mar 1 00:09:32.251: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.12.1  

(FastEthernet0/1) is resync: peer graceful-restart 

 

Verification: – 

 

R1#show ip route eigrp  

     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks 

D 172.16.0.0/23 is a summary, 00:00:57, Null0 

 

R2#show ip route eigrp  

     172.16.0.0/23 is subnetted, 1 subnets 

D 172.16.0.0 [90/409600] via 192.168.12.1, 00:00:15, FastEthernet0/1 

 

R2#ping 172.16.0.1 

 

Type escape sequence to abort. 

Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds: 

!!!!! 

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/10/12 ms 

 

After summarization also we can ping 172.16.0.1 hence this network is reachable.

Leave a Comment

This site uses Akismet to reduce spam. Learn how your comment data is processed.