Network Kings

LIMITED TIME OFFER

$999 $499 only For All Access Pass Today! USE PROMO CODE : LIMITED

d :
h :
m

Multi-area OSPF Lab

Multi-area Open Shortest Path First Lab

In this lesson, we will do a multi-area OSPF Lab.

To perform this lab I used Cisco packet tracer,  8 routers and 2 switches.
Before making multi-area OSPF network design, 3 things always keep in mind.

  1. Area 0 (backbone area) is must, other areas can’t communicate without area 0.
  2. All area should be connected with area 0.
  3. Area should be continuous.
Multi-area OSPF Lab

In this network topology each router is showing different location. In above diagram RID (router Id) is mentioned in red box. IP address of each interface is represented in yellow box. This is the right design for OSPF multi-area as we can see, this topology has area 0, each area is connected to area 0.

By seeing configuration, many of you are thinking this is very lengthy configuration, yes configuration is lengthy I agree, but no need to worry believe me it’s quite simple. Once you understand the steps and commands, which I follow it will be easy peasy task for you.


For easy understanding, here I am dividing each router configuration in 3 parts.

For assign IP address to router interfaces

interface <interface type> <interface name>
ip address <IP address> <subnet mask>
no shutdown

For router Id (RID), I configure loopback.

interface loopback <loopback name>
ip address <IP address> <subnet mask>

To configure OSPF

router OSPF <process id>
    
router-id <IP address> ----—here in the field of IP address, mention IP address that you assign to the loopback. For example in router 3,
I assign 192.168.100.8 ip address to loopback 0 interface. So, in R3, I write this command as

router-id 192.168.100.8
network <network Id> <wildcard mask> area <area number>

These set of commands are used in each router in exact sequence as I mentioned above, only the values are changed.

## R3 configuration ##

enable 
configure terminal
hostname R3
interface fa0/1
ip address 192.168.20.1 255.255.255.0
no shutdown
interface fa0/0
ip address 192.168.30.2 255.255.255.0
no shutdown
interface loopback 0
ip address 192.168.100.8 255.255.255.0
router ospf  1
router-id 192.168.100.8
network 192.168.30.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0

## R8 Configuration ##

enable 
configure terminal
hostname R8
interface fa0/1
ip address 192.168.10.1 255.255.255.0
no shutdown
interface fa0/0
ip address 192.168.30.1 255.255.255.0
no shutdown
interface loopback 0
ip address 192.168.100.8 255.255.255.0
router ospf  1
router-id 192.168.100.8
network 192.168.30.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0

## R1 Configuration ##

enable 
configure terminal
hostname R1
int fa0/0
ip address 192.168.10.2 255.255.255.0
no shut
int fa0/1
ip add 192.168.40.1 255.255.255.0
no shutdown
int fa1/0
ip add 192.168.50.1 255.255.255.0
no shutdown
interface loopback 0
ip add 192.168.100.1 255.255.255.0
router ospf 1
router-id 192.168.100.1
network 192.168.50.0 0.0.0.255 area 1
network 192.168.10.0 0.0.0.255 area 0
network 192.168.40.0 0.0.0.255 area 0

## R2 Configuration ##

enable 
configure terminal
hostname R2
int fa0/0
ip add 192.168.40.2 255.255.255.0
no sh
int fa1/0
ip add 192.168.60.1 255.255.255.0
no sh
int fa0/1
ip add 192.168.20.2 255.255.255.0
no sh
interface loopback 0
ip add 192.168.100.2 255.255.255.0
router ospf 1
router-id 192.168.100.2
network 192.168.60.0 0.0.0.255 area 2
network 192.168.40.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0

## R4 Configuration ##

enable
configure terminal
hostname  R4
int fa0/0
ip add 192.168.50.2 255.255.255.0
no sh
interface loopback 0
ip add 192.168.100.4 255.255.255.0
router ospf  1
router-id 192.168.100.4
network 192.168.50.0 0.0.0.255 area 1

## R5 Configuration ##

en
conf t
hostname  R5
int fa0/0
ip add 192.168.50.3 255.255.255.0
no sh
interface loopback 0
ip add 192.168.100.5 255.255.255.0
router ospf  1
router-id 192.168.100.5
network 192.168.50.0 0.0.0.255 area 1

## R6 Configuration ##

enable
conf t
hostname  R6
int fa0/0
ip add 192.168.60.2 255.255.255.0
no sh
interface loopback 0
ip add 192.168.100.6 255.255.255.0
router ospf  1
router-id 192.168.100.6
network 192.168.60.0 0.0.0.255 area 2

## R7 Configuration ##

enable
conf t
hostname  R7
int fa0/0
ip add 192.168.60.3 255.255.255.0
no sh
interface loopback 0
ip add 192.168.100.7 255.255.255.0
router ospf  1
router-id 192.168.100.7
network 192.168.60.0 0.0.0.255 area 2

Result of Multi-area OSPF lab:

Here I am submitting my ping result. Now, it’s your turn do lab and tell me below in the comment section you got ping reply or not. If not, then tell me which problem are you facing? Also, if you have any query regarding multi-area OSPF lab please feel free to write.

 

                              Multi-area OSPF lab ping result !